import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(/|\\w|\\.\\w|\\s|-|'|\\\"|\\||\\(|\\[|]\\||\\)|\\.|\\*|\\\\|\\\\|\\:\\=)*";
final String string = "config -p \"AAP|LBV|LBA\".* --eds DEI039 --os BIG-IP -d -s '\\\"\\\\\\\"rule_debug\\\\\\\" := \\\\\\\"1\\\\\\\"'";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}