// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^(/|\w|\.\w|\s|-|'|\"|\||\(|\[|]\||\)|\.|\*|\\|\\|\:\=)*"#).unwrap();
let string = "config -p \"AAP|LBV|LBA\".* --eds DEI039 --os BIG-IP -d -s '\\\"\\\\\\\"rule_debug\\\\\\\" := \\\\\\\"1\\\\\\\"'";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}