package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<name>\S+) (?<mac>\w\w:\w\w:\w\w:\w\w:\w\w:\w\w) \V*$`)
var str = `2 access point on the Site Name network regained contact with the Meraki cloud.
AP1 e4:55:a8:2d:8c:65 11:27 AM GMT on Mar 26
AP2 e4:55:a8:2d:8c:66 11:27 AM GMT on Mar 26
Cisco Meraki
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}