$re = '/^(?<name>\S+) (?<mac>\w\w:\w\w:\w\w:\w\w:\w\w:\w\w) \V*$/m';
$str = '2 access point on the Site Name network regained contact with the Meraki cloud.
AP1 e4:55:a8:2d:8c:65 11:27 AM GMT on Mar 26
AP2 e4:55:a8:2d:8c:66 11:27 AM GMT on Mar 26
Cisco Meraki
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);