import Foundation
let pattern = #"^(?<name>\S+) (?<mac>\w\w:\w\w:\w\w:\w\w:\w\w:\w\w) \V*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
2 access point on the Site Name network regained contact with the Meraki cloud.
AP1 e4:55:a8:2d:8c:65 11:27 AM GMT on Mar 26
AP2 e4:55:a8:2d:8c:66 11:27 AM GMT on Mar 26
    Cisco Meraki
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
    var groups: [String] = []
    for rangeIndex in 1 ..< match.numberOfRanges {
        let nsRange = match.range(at: rangeIndex)
        guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
        let string = (testString as NSString).substring(with: nsRange)
        groups.append(string)
    }
    if !groups.isEmpty {
        result.append(groups)
    }
}
print(result)