import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<name>\\S+) (?<mac>\\w\\w:\\w\\w:\\w\\w:\\w\\w:\\w\\w:\\w\\w) \\V*$";
final String string = "2 access point on the Site Name network regained contact with the Meraki cloud.\n\n"
+ "AP1 e4:55:a8:2d:8c:65 11:27 AM GMT on Mar 26\n"
+ "AP2 e4:55:a8:2d:8c:66 11:27 AM GMT on Mar 26\n\n"
+ " Cisco Meraki\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}