package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\+[0-9]{1,3} ?[0-9]{10}$`)
var str = `+441213315000
+1 2323214316
+2923432432432
+225 0546568022`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}