// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\+[0-9]{1,3} ?[0-9]{10}$").unwrap();
let string = "+441213315000
+1 2323214316
+2923432432432
+225 0546568022";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}