re = /^\+[0-9]{1,3} ?[0-9]{10}$/m
str = '+441213315000
+1 2323214316
+2923432432432
+225 0546568022'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end