package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^/uslugi/([a-zA-Z0-9\\.\\-_]+)/([^/]*)`)
var str = `/uslugi/test/?hello
/uslugi/some.link
/uslugi/some.link/
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}