const regex = new RegExp('^/uslugi/([a-zA-Z0-9\\\\.\\\\-_]+)/([^/]*)', 'gm')
const str = `/uslugi/test/?hello
/uslugi/some.link
/uslugi/some.link/
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}