package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^a-z\/{1}\s]`)
var str = `SHOULDNOTMATCH
some_
über
ässs
schleißheim
some?sd
some/7asa+
some one
shouldnotmatche//
shouldmatch
dont'allow /home//some/where/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}