import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^a-z\\/{1}\\s]";
final String string = "SHOULDNOTMATCH\n"
+ "some_\n"
+ "über\n"
+ "ässs\n"
+ "schleißheim\n"
+ "some?sd\n"
+ "some/7asa+\n"
+ "some one\n"
+ "shouldnotmatche//\n"
+ "shouldmatch\n"
+ "dont'allow /home//some/where/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}