$re = '/[^a-z\/{1}\s]/m';
$str = 'SHOULDNOTMATCH
some_
über
ässs
schleißheim
some?sd
some/7asa+
some one
shouldnotmatche//
shouldmatch
dont\'allow /home//some/where/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);