const regex = /[^a-z\/{1}\s]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^a-z\\\/{1}\\s]', 'gm')
const str = `SHOULDNOTMATCH
some_
über
ässs
schleißheim
some?sd
some/7asa+
some one
shouldnotmatche//
shouldmatch
dont'allow /home//some/where/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}