#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(.*facebook.com.groups.*|.*meetup.com.*)"
Local $sString = "facebook.com/groups/" & @CRLF & _
"facebook.com" & @CRLF & _
"facebook.com/groups/12245" & @CRLF & _
"facebook.com/groups" & @CRLF & _
"meetup.com "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")