$re = '/(.*facebook.com.groups.*|.*meetup.com.*)/';
$str = 'facebook.com/groups/
facebook.com
facebook.com/groups/12245
facebook.com/groups
meetup.com ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);