using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*facebook.com.groups.*|.*meetup.com.*)";
string input = @"facebook.com/groups/
facebook.com
facebook.com/groups/12245
facebook.com/groups
meetup.com ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}