import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(https|git)(:\\/\\/|@)([^\\/:]+)[\\/:]([^\\/:]+)(?:\\/(.+).git)?$";
final String string = "git://github.com/some-user/my-repo.git\n"
+ "git@github.com:some-user/my-repo.git\n"
+ "https://github.com/some-user/my-repo.git\n\n"
+ "git://github.com/some-user\n"
+ "git@github.com:some-user\n"
+ "https://github.com/some-user\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}