const regex = new RegExp('^(https|git)(:\\/\\/|@)([^\\/:]+)[\\/:]([^\\/:]+)(?:\\/(.+).git)?$', 'gm')
const str = `git://github.com/some-user/my-repo.git
git@github.com:some-user/my-repo.git
https://github.com/some-user/my-repo.git
git://github.com/some-user
git@github.com:some-user
https://github.com/some-user
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}