#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)dog walker|dog"
Local $sString = "dog walker and a dog"
Local $sSubst = "<a href="#" class="glossary-item">$&</a>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)