re = /dog walker|dog/m
str = 'dog walker and a dog'
subst = '<a href="#" class="glossary-item">$&</a>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result