const regex = /dog walker|dog/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('dog walker|dog', 'gm')
const str = `dog walker and a dog`;
const subst = `<a href="#" class="glossary-item">$&</a>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);