// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)dog walker|dog").unwrap();
let string = "dog walker and a dog";
let substitution = "<a href=\"#\" class=\"glossary-item\">$&</a>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}