import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?>([^(]*?)\\s*([(]([^()]*|(?R))*[)])([^)]*?)\\s*)";
final String string = "SU 3180 and \n"
+ "(CMG 3200 or SU 3210 or \n"
+ " (CMG 3200 or \n"
+ " (CMG 3200 or SU 3210 and \n"
+ " (CMG 3200 or SU 3210)\n"
+ " )\n"
+ " )\n"
+ ")";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}