re = /(?>([^(]*?)\s*([(]([^()]*|(?R))*[)])([^)]*?)\s*)/
str = 'SU 3180 and
(CMG 3200 or SU 3210 or
(CMG 3200 or
(CMG 3200 or SU 3210 and
(CMG 3200 or SU 3210)
)
)
)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end