$re = '/(?>([^(]*?)\s*([(]([^()]*|(?R))*[)])([^)]*?)\s*)/s';
$str = 'SU 3180 and
(CMG 3200 or SU 3210 or
(CMG 3200 or
(CMG 3200 or SU 3210 and
(CMG 3200 or SU 3210)
)
)
)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);