import re
regex = re.compile(r"(?>([^(]*?)\s*([(]([^()]*|(?R))*[)])([^)]*?)\s*)", flags=re.DOTALL)
test_str = ("SU 3180 and \n"
"(CMG 3200 or SU 3210 or \n"
" (CMG 3200 or \n"
" (CMG 3200 or SU 3210 and \n"
" (CMG 3200 or SU 3210)\n"
" )\n"
" )\n"
")")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")