# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^|;)ab@xyz\.com;/$1/gm;t' <<< "ab@xyz.com;cab@xyz.com;c-ab@xyz.com;c.ab@xyz.com;c_ab@xyz.com;"