re = /(^|;)ab@xyz\.com;/m
str = 'ab@xyz.com;cab@xyz.com;c-ab@xyz.com;c.ab@xyz.com;c_ab@xyz.com;'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result