import re
regex = re.compile(r"(^|;)ab@xyz\.com;", flags=re.MULTILINE)
test_str = "ab@xyz.com;cab@xyz.com;c-ab@xyz.com;c.ab@xyz.com;c_ab@xyz.com;"
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)