const regex = /(^|;)ab@xyz\.com;/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|;)ab@xyz\\.com;', 'gm')
const str = `ab@xyz.com;cab@xyz.com;c-ab@xyz.com;c.ab@xyz.com;c_ab@xyz.com;`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);