package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d+`)
var str = `8910823904 asdf1234asdf 190pgsq01
oi91io10o3io4o5o6o0
0000000aaaaaaaa1111111bbbbbbb222222ccccc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}