// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\d+").unwrap();
let string = "8910823904 asdf1234asdf 190pgsq01
oi91io10o3io4o5o6o0
0000000aaaaaaaa1111111bbbbbbb222222ccccc";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}