$re = '/\d+/';
$str = '8910823904 asdf1234asdf 190pgsq01
oi91io10o3io4o5o6o0
0000000aaaaaaaa1111111bbbbbbb222222ccccc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);