re = /\d+/
str = '8910823904 asdf1234asdf 190pgsq01
oi91io10o3io4o5o6o0
0000000aaaaaaaa1111111bbbbbbb222222ccccc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end