#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\[([^]]+)\] => (?:Array(*SKIP)(*FAIL)|(.*)\s+)"
Local $sString = "Array" & @CRLF & _
"(" & @CRLF & _
" [0] => 32" & @CRLF & _
" [1] => Array" & @CRLF & _
" (" & @CRLF & _
" [uuid] => 92bbf05c-b49e-4950-9d4a-69c226325131" & @CRLF & _
" [conversation_uuid] => CON-ee2287cb-ddb7-47e3-9595-0b4d36ac57e3" & @CRLF & _
" [status] => failed" & @CRLF & _
" [direction] => outbound" & @CRLF & _
" )" & @CRLF & _
"" & @CRLF & _
")" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")