package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[([^]]+)\] => (?:Array(*SKIP)(*FAIL)|(.*)\s+)`)
var str = `Array
(
[0] => 32
[1] => Array
(
[uuid] => 92bbf05c-b49e-4950-9d4a-69c226325131
[conversation_uuid] => CON-ee2287cb-ddb7-47e3-9595-0b4d36ac57e3
[status] => failed
[direction] => outbound
)
)
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}