import re
regex = re.compile(r"\[([^]]+)\] => (?:Array(*SKIP)(*FAIL)|(.*)\s+)")
test_str = ("Array\n"
"(\n"
" [0] => 32\n"
" [1] => Array\n"
" (\n"
" [uuid] => 92bbf05c-b49e-4950-9d4a-69c226325131\n"
" [conversation_uuid] => CON-ee2287cb-ddb7-47e3-9595-0b4d36ac57e3\n"
" [status] => failed\n"
" [direction] => outbound\n"
" )\n\n"
")\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")