const regex = /^(?<classname>[\w\.]+)?(?:#(?<member>\w+))?(?:\((?<params>.*)\))?(?:\s(?<label>\w+(?:\s\w+)*))?$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<classname>[\\w\\.]+)?(?:#(?<member>\\w+))?(?:\\((?<params>.*)\\))?(?:\\s(?<label>\\w+(?:\\s\\w+)*))?$', 'mg')
const str = `Moo#withRecipientsWithDefaultName(String, Collection, RecipientType) label
#withRecipientsWithDefaultName(String, Collection, RecipientType) label
#withRecipientsWithDefaultName(String, Collection, RecipientType)
#withRecipientsWithDefaultName
Moo#withRecipientsWithDefaultName label
#withRecipientsWithDefaultName label
ClassName myLabel
ClassName#member
ClassName my label
ClassName
org.company.ClassName`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}