import re
regex = re.compile(r"^(?<classname>[\w\.]+)?(?:#(?<member>\w+))?(?:\((?<params>.*)\))?(?:\s(?<label>\w+(?:\s\w+)*))?$", flags=re.MULTILINE)
test_str = ("Moo#withRecipientsWithDefaultName(String, Collection, RecipientType) label\n"
"#withRecipientsWithDefaultName(String, Collection, RecipientType) label\n"
"#withRecipientsWithDefaultName(String, Collection, RecipientType)\n"
"#withRecipientsWithDefaultName\n"
"Moo#withRecipientsWithDefaultName label\n"
"#withRecipientsWithDefaultName label\n"
"ClassName myLabel\n"
"ClassName#member\n"
"ClassName my label\n"
"ClassName\n"
"org.company.ClassName")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")