use strict;
my $str = 'Moo#withRecipientsWithDefaultName(String, Collection, RecipientType) label
#withRecipientsWithDefaultName(String, Collection, RecipientType) label
#withRecipientsWithDefaultName(String, Collection, RecipientType)
#withRecipientsWithDefaultName
Moo#withRecipientsWithDefaultName label
#withRecipientsWithDefaultName label
ClassName myLabel
ClassName#member
ClassName my label
ClassName
org.company.ClassName';
my $regex = qr/^(?<classname>[\w\.]+)?(?:#(?<member>\w+))?(?:\((?<params>.*)\))?(?:\s(?<label>\w+(?:\s\w+)*))?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}