re = /^(?<classname>[\w\.]+)?(?:#(?<member>\w+))?(?:\((?<params>.*)\))?(?:\s(?<label>\w+(?:\s\w+)*))?$/m
str = 'Moo#withRecipientsWithDefaultName(String, Collection, RecipientType) label
#withRecipientsWithDefaultName(String, Collection, RecipientType) label
#withRecipientsWithDefaultName(String, Collection, RecipientType)
#withRecipientsWithDefaultName
Moo#withRecipientsWithDefaultName label
#withRecipientsWithDefaultName label
ClassName myLabel
ClassName#member
ClassName my label
ClassName
org.company.ClassName'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end