$re = '/^(?!.*?([abcde]).*\1)(?1){5}$/m';
$str = 'Should pass:
abcde
Should fail:
Too short:
abcd
Too long
abcdef
Missing required char:
fghij
Duplicates:
aaaaa
abcbc
afgha
fgaah
Previously-passing cases:
afghi
fgahi
fghia';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);