re = /^(?!.*?([abcde]).*\1)(?1){5}$/m
str = 'Should pass:
abcde
Should fail:
Too short:
abcd
Too long
abcdef
Missing required char:
fghij
Duplicates:
aaaaa
abcbc
afgha
fgaah
Previously-passing cases:
afghi
fgahi
fghia'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end