import re
regex = re.compile(r"^(?!.*?([abcde]).*\1)(?1){5}$", flags=re.MULTILINE)
test_str = ("Should pass:\n"
"abcde\n\n"
"Should fail:\n"
"Too short:\n"
"abcd\n"
"Too long\n"
"abcdef\n"
"Missing required char:\n"
"fghij\n"
"Duplicates:\n"
"aaaaa\n"
"abcbc\n"
"afgha\n"
"fgaah\n"
"Previously-passing cases:\n"
"afghi\n"
"fgahi\n"
"fghia")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")