package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)(<p class="bodytext">)(.+?)(<\/p>)`)
var str = []byte(`<p class="bodytext">
• This is some random text.<br>
• This is some other random text.<br>
• This is another random text.
</p>`)
var substitution = []byte("<ul>\2</ul>")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}