const regex = /(<p class="bodytext">)(.+?)(<\/p>)/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<p class="bodytext">)(.+?)(<\\\/p>)', 's')
const str = `<p class="bodytext">
• This is some random text.<br>
• This is some other random text.<br>
• This is another random text.
</p>`;
const subst = `<ul>\2</ul>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);