use strict;
my $str = '<p class="bodytext">
• This is some random text.<br>
• This is some other random text.<br>
• This is another random text.
</p>';
my $regex = qr/(<p class="bodytext">)(.+?)(<\/p>)/sp;
my $subst = '<ul>\\2</ul>';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";