// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?s)(<p class="bodytext">)(.+?)(<\/p>)"#).unwrap();
let string = "<p class=\"bodytext\">
• This is some random text.<br>
• This is some other random text.<br>
• This is another random text.
</p>";
let substitution = "<ul>\\2</ul>";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}